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1/ Introduction 

 

Welcome!  

You just purchased Guitar Pro 7, congratulations and welcome to the Guitar Pro 

family! Guitar Pro is back with its best version yet. Faster, stronger and 

modernised, Guitar Pro 7 offers you many new features. Whether you are a 

longtime Guitar Pro user or a new user you will find all the necessary 

information in this user guide to make the best out of Guitar Pro 7. 

 

2/ Getting started 

2/1/ Installation 

 

2/1/1 MINIMUM SYSTEM REQUIREMENTS 

 

macOS X 10.10 / Windows 7 (32 or 64-Bit)  

Dual-core CPU with 4 GB RAM 

2 GB of free HD space 

960x720 display 

OS-compatible audio hardware 

DVD-ROM drive or internet connection required to download the software 

 

2/1/2/ Installation on Windows 

 

Installation from the Guitar Pro website: 

 

You can easily download Guitar Pro 7 from our website via this link: 

https://www.guitar-pro.com/en/index.php?pg=download 

 

Once the trial version downloaded, upgrade it to the full version by entering 

your licence number into your activation window. 

 

Installation from the Guitar Pro 7  DVD-ROM: 

 

Insert the Guitar Pro 7 DVD-ROM in your drive.  

https://www.guitar-pro.com/en/index.php?pg=download


If the setup program does not start automatically, double-click on My Computer, 

double-click on CD-ROM drive, then double-click on guitar-pro-7-setup.exe file 

and follow the instructions.  

You will be asked to accept the terms of the license of use and then select the 

setup directory for the software.  

 

Note: you do not have to download RSE soundbanks separately anymore as they are 

now included with your installation package. 

 

 

2/1/3/ Installation on macOS X 

 

Installation from the Guitar Pro website: 

 

You can easily download Guitar Pro 7 from the website via this link 

https://www.guitar-pro.com/en/index.php?pg=download 

 

Once the trial version downloaded, upgrade it to the full version by entering 

your licence number into your activation window. 

 

Installation from the Guitar Pro 7  DVD -ROM: 

 

Insert the Guitar Pro DVD-ROM in your DVD drive. Double-click on the DVD-Rom 

that has appeared on your desktop, then double-click on the guitar-pro-7-

setup.pkg  file and follow the instructions. 

You will be asked to accept the terms of the license of use and will let you select 

the setup directory for the software. 

 

Note: you do not have to download RSE soundbanks separately anymore as they are 

now included with your installation package. 

 

 

2/1/4 Guitar Pro 7 updates 

 

Guitar Pro 7 updates are free. By default  Guitar Pro 7 will check if an update is 

available every week. You can change this periodicity from the Preferences 

window, General tab (Guitar Pro 7 > Preferences menu on macOS or File > 

https://www.guitar-pro.com/en/index.php?pg=download


Preferences menu on Windows). Still you can manually update Guitar Pro 7 

from the program itself as follow: 

 

Go to Guitar Pro 7 > Check for updates on macOS X. 

Go to Help > Check for updates on Windows. 

 

 

2/2/ Overview 

 

2/2/1/ Guitar Pro 7, what is it? 

 

Guitar Pro is a complete workshop for all guitarists — beginning or advanced — 

who wish to improve, write music, or simply use a virtual backing band. Guitar 

Pro 7 supports all fretted instruments from 4 to 8 strings (guitars, basses, banjo, 

mandolin, and so on), as well as all and any instruments that can be in your 

band or orchestra.  

 

Here’s what Guitar Pro offers you:  

 

● A complete yet user-friendly multitrack, tablature-centered score editor 

for stringed instruments, which includes all the usual symbols and 

specificities of those instruments. 

 

● Optimized screen-display options and a powerful audio engine designed 

to yield faithful playback of the sounds and effects of all types of guitars 

as well as of a hundred other instruments (bass, strings, piano, drums, 

etc.), from samples and modelized sounds of amps and effect units 

recorded in a professional studio. 

 

● Everyday tools for practice, such as the tuner, the chord engine, the scale 

engine, the guitar fretboard, etc.. 

 

● Opening out onto the world, with the many import/export functions 

allowing you to make the most of hundreds of thousands of scores 

available on the Internet. 



 

● mySongBook gives you access to a sheet music library directly from Guitar 

Pro 6. Improve your guitar skills with accurate, totally secure and legal 

scores. You do not have Guitar Pro? No problem, get access to our 

collection through the brand new mySongBook Player available on our 

website page. It consists in a free and totally stand-alone Player. 

 

 

A few important points to understand how Guitar Pro works: 

              

Custom display options: you can work with a “page”-type of display for your 

score, or in screen mode (horizontal or vertical) so as to make the most of the 

available space on your screen. You can also choose a full-screen mode, or a “2-

page” mode. 

You may change the proportions and the page settings of your document at any 

time, with the Stylesheet. You can also select whichever tracks you want to be 

visible. 

 

Automatic page setup: Guitar Pro automatically adjusts the vertical placement of 

the various elements of the score. Note- capturing is made very fast, for a result 

that is equivalent to professional songbooks. 

      

Musical accuracy: Guitar Pro automatically adds the barlines and checks the 

synchronization of the various tracks. Your score thus remains consistent in 

terms of musical rules. Such rigour may appear constraining to the beginner, but 

it proves very pedagogical in the end, and is essential anyway for the score to be 

played correctly. 

      

Interactive tools: each Guitar Pro tool relates to the attributes of the active track. 

Whether you are using the chord engine, the scale analyst, or the tuner, all the 

results you get will thus be consistent with the tuning chosen for the current 

track.  

     

    

2/2/2/ What are Guitar Pro 7 main features ? 

 

Editing professional- looking scores:  



You can edit your notes directly on the standard score or on the tablature. All 

the usual musical symbols pertaining to the guitar and to other stringed 

instruments are available.  

 

Reading music scores & tabs: 

Guitar Pro users can play back, listen to and view any scores, to write music or 

learn how to play new songs.  

 

Tools that simplify songwriting: 

Our chord / scale generator, lyrics editor, polyphonic tuner, and virtual 

instruments (guitar, bass, keyboard, and drums) are included for composing 

musicians.  

 

Audio mixing: 

The audio engine offers more than 100 world-class licensed soundbanks 

(realistic instrument sounds), pedals and amps. 

It allows the user to customize the sounds of their files as they wish.  

 

Sharing and printing files: 

Guitar Pro makes it easy to print, e-mail scores, or save them onto an external 

drive at any time. Many import and export formats are supported (MIDI, 

MusicXML, ASCII, TablEdit, PowerTab, PDF).  

 

 

Line In: 

Plug your guitar in and enjoy the built-in effects and amp models used in the 

Guitar-Pro track of your choice. If the file is multi-track, you can learn the guitar 

solo and let the software play the bass and drums tracks along.  

 

 

2/2/3/ Discover Guitar Pro 7  main screen 

 



 

 

2/2/4/ Panels and Inspectors. 

  

The Edition palette (1):  

Located on the left side of your window, the Edition palette contains all of the 

symbols you need to write a score, in standard as well as tablature notation, or 

in rhythmical “slash” notation. You just need to click on a button for the 

corresponding element or attribute to be affected to the note or notes you have 

selected. (For the symbols demanding some precisions, a dialog window opens 

up for you to select the desired symbol.)  

  

Inspectors (2): 

Two inspectors are located on the right side of your Guitar Pro 7 window. 

 

The Song Inspector: 

Access to the song properties, set up your notation options and finalise  your 

sound mastering settings. 

 

The Track Inspector:  

Access to the track properties, notation and tuning options, sound and 

interpretation settings. 

 



Global view (3): 

The Soundboard, along with the Global View, allows for an audio tuning of each 

track and a synthetic view of the score being played, in which you can click 

directly to access a bar. You can also select multiple tracks in the Global view 

(which is useful if you want to copy/paste easily many bars)  

 

Toolbar (4): 

Located at the top of your Guitar Pro 7 window, the toolbar allows you to quickly 

access the playing and view options and includes a direct access to the 

metronome, count-in, tempo, speed trainer, tuner, virtual instruments, global 

tonality and line in features. 

 

 

 

Work area: 

Located at the center of your window, the work area is simply where you write 

your tracks and work on your scores by adding notes to your composition.  

 

Note: You have the possibility to either hide or display the Edition Palette, the Global 

View and the Inspectors panel. Simply select the view icon located at the top left of 

your window from the toolbar in order to hide or show these elements. 

 

  

2/3/ New features     

      

1/ Brand-new graphical user interface 

Removable side panels and toolbar are added to the interface to facilitate access 

to the software’s main features in one click.  

      

2/ Tablature for all tracks 

Convert standard music notation into guitar tablature automatically.  

         

3/ New audio processing  



Hundreds of instrumental sounds are included in the software for you to 

customise your Guitar Pro render sound into anything you want and make your 

files play exactly like your favorite song.  

 

4/ MP3 audio exporting 

New audio output formats: MP3, FLAC and OGG.  

 

5/ Line in: 

Plug your guitar in and enjoy the built-in effects and amp models used in the 

Guitar-Pro track of your choice. 

If the file is multi-track, you can learn the guitar solo and let the software play 

the bass and drums tracks along.  

 

6/ Polyphonic tuner  

Just one brush-down stroke allows you to check the tuning of all six strings at 

once.  

 

2/4/ Understanding notation 

 

2/4/1/ Reading tablature 

       

It is recommended that you know how to read tablature and have a few notions 

of rhythm before you use Guitar Pro. Following is a quick overview of some basic 

notions.     

            

Tablature notation was created to make music easier to read for fretted 

instruments. It can be learned quickly, and you do not really need to know any 

musical theory. What it shows are the strings that are played, which actually is 

important since any given note can be played on different strings. 

       

Each guitar string is represented by a line. The numbers indicate on which frets 

the fingers must press to play the notes. “0” means that the string is played open 

— that is, without pressing on any fret. The lowest line represents the lowest-

pitched string (low E), while the top line represents the highest-pitched string of 



the guitar (high E). This actually corresponds to what you see when you lean over 

your guitar, as opposed to what you see when you are facing it.  

      

     

2/4/2/ Understanding rhythm   

       

Notes can have different durations. A note’s duration is not expressed in 

seconds, but as a multiple of the tempo. A quarter note is one beat. The tempo 

is expressed in bpm (beats per minute). So if the tempo is 60, a quarter note 

lasts 1 second. If the tempo is 120, the quarter note is 1⁄2 second. The other 

notes are defined relative to the whole note — on the staff below are a whole 

note (bar 1), then two half-notes (bar 2), four quarter-notes (bar 3), and eight 

eighth-notes (bar 4):  

         

 

               

When a note is dotted, its duration is one and a half times its original value 

(x1.5):    

N-tuplets (triplets, quintuplets, sextuplets...) consist in playing a certain number 

of notes in a given time-spam. For example, a triplet of eighth notes (3 x 1⁄2 

beats = 1.5 beat) is played on one beat; or a quintuplet of eighth notes (5 x 1⁄2 

beats = 2.5 beats) also on one beat.      

     

2/4/3/ Time and key signature 

          

The time signature sets the number of beats per bar. For example, for a time 

signature of 3⁄4: the 4 indicates that the reference time is the quarter note, and 

the 3 indicates that there are 3 beats per bar. In this case, there are 3 quarter-

notes in a bar.      

The key signature tells you what accidentals (sharps or flats) are systematic in 

the score. 

 



  

2/5/ Technical support 

 

2/5/1/ Before contacting technical support 

 

Prior to contact technical support please make sure to install the last available 

version of Guitar Pro 7.  

Go to Guitar Pro 7 > Check for updates (macOS) or Help > Check for updates 

(Windows). 

 

2/5/2/ Ressources 

 

You will find many useful resources available from our website, please check the 

Support section from www.guitar-pro.com. We invite you to check this section 

prior to contact us. 

 

2/5/3/ Contact technical support 

 

If you did not find the answer to your question among the available resources, 

feel free to contact us and fill in the web form available from the Support 

section. We’ll be happy to help. 

Please provide any useful information regarding your issue, steps to reproduce, 

operating system, etc… 

 

3/ Use Guitar Pro 7  

3/A/1/ Writing a score 

 

Guitar Pro 7 makes it possible to work on several files at the same time. Each file 

will appear under a tab above the score’s window.  

To create a new score in Guitar Pro, you need to follow these steps.  

 

3/A/1/1/ Creating a new score  

http://www.guitar-pro.com/


 

Use the File > New menu: 

This menu opens a blank new score, you then have the possibility to start your 

score from scratch. 

 

Use the File > New from template: 

Create a new score from one of the available predefined template. 

 

You also have the possibility to create a new score, choose one of the available 

templates or one of your recent files from the “welcome to Guitar Pro 7 “ 

window which pop up when you open Guitar Pro 7. 

 

 

 

3/A/1/2/ Key signature 

From the Edition panel, click on to open the Key signature window. 

Select the key and the mode (major or minor) of the score. If you do not know 

which it is, you can leave the default value (C major), as it will not change the 

standard notation. 

Click OK to continue. 

            

From this window you have the possibility to enable the concert tone or the 

transposition tone. 

 

The concert tone is what a conductor uses. The notes displayed are the ones you 

actually hear. The transposing tone is what the musicians use; it is mostly used 

for wind instruments, and refers more to the position of their fingers than to the 

actual melody. For instance, for someone playing a Bb clarinet the Bb will appear 

as a C — with every other note being correspondingly shifted, and the key 

signature as well: the Bb-tone signature will bear no accidentals, just like a C 

tone.  

       



 

 

The transposition in Guitar Pro 7 applies only to the note, the octave, the capo 

and the selected octave. 

3/A/1/3/ Choosing a clef 

 

The instrument you select for the track will automatically set a G or F Clef, but 

you can also change it by clicking on in the edition palette.  

       

 

 

 3/A/1/4/Setting the signature and triplet feel. 

 

Click on  or go the Bar > Time signature menu to open the Time Signature 

window. 



       

Choose a signature for the score (it is set by default on 4/4). The time signature 

determines the number of beats in each bar. In that window you can also 

choose how to link the beams by default. 

       

Click OK to continue. 

Click on  to choose a triplet-feel for your score. Guitar Pro 7 offers 6 

different kinds. 

       

 

Click OK to validate. 

      

 

3/A/1/5/ Managed transposed instruments 

 

When a guitar is tuned with a non standard tuning (half tone below for example), 

it is easier to consider that the instrument kept its standard tuning and as a 

result keep your usual habits and marks. 

It is then necessary to transpose the standard notation, this one does not 

necessarily reflect the pitch of the note but instead the right tune based on the 

standard tuning. This is what the transposition tonality allows. 

 

The setting up of a transposed guitar notation in your score depends of the 

application of the option “capo and translated impact standard notation” 

available from the System and staves tab of the Stylesheet (F7). 

 



Here are two scenarios: 

 

Example 1, the option is selected: 

 

When this option is selected, the notation reflects the notes actually heard. The 

key signature will be identical for both the guitar track and for the vocal track. 

The correct clef is selected (B, 5#), which will prevent accidental alterations on 

both tracks, but this choice is not recommended when we use the standard 

notation as a reference on the guitar track. 

Indeed we are more used to read and play the guitar in standard tuning, as a 

result we instinctually play a E by playing the opened E string on the guitar. 

In this situation a E will have to be played from the first fret of the opened E 

string which force us to transpose our playing compared to our reading habits. 

It is easier to display a transposed notation for your reading and so keep your 

usual reading habits. 

 

 

 

Example 2 the option is unchecked: 

 

Once this option selected a transposition will be automatically applied on the 

guitar track in order to compensate the modified tuning or the capodastre. The 

notation will no longer reflect the real pitch of the notes, but the reading is 

easier as we use a standard tuning. 

 



 

 

The correct tonality is chosen (B, 5 #) for the vocal track, using the transposition 

settings on the guitar track we have now a correct key signature on each track, 

allowing us an easier reading and avoiding accidental alterations. 

You can notice that the transposition has been modified in the Transposition 

tonality section of the track inspector.  

 

 

 

 

Transposing instruments: 

It is possible to set up a transposition tonality for each track from the 

Transposition tonality section of the track inspector. 

 



 

 

This option allows you to automatically manage the displaying of transposing 

instruments such as trumpet, saxophone, etc… 

 

You just need to select (from the scrolling menu) which note will be heard for a 

written C in the score. 

 

Note: the concert tone has a direct impact on the transposition. The 

transposition is only valid when the concert tone is deactivated, otherwise the 

displayed notes are the interpreted notes. 

 

3/A/2/ Tracks in Guitar Pro 7 

 

3/A/2/1/ Add a new track 

 

Guitar Pro can handle a virtually unlimited number of simultaneous tracks (the 

limit being what your computer can handle). The instrument you choose 

determines what type of staff you get — Grand staff for piano, tablature for 

guitar, and so on. Besides, this also sets the range of the instrument, and the 

notes that are out of range may appear in red. (See Stylesheet.)  

      

To add a new track go to the Track > Add menu. 

 



 

 

The instrument window pops up, this window allows you to configure your track 

settings. 

 

Choose your instrument type between: stringed, orchestra, drums, MIDI. 

 

Then select the instrument of your choice in the lower instrument division. 

 

Set up the information related to your track: name, allocated color, icon. 

 

Select your notation type: standard, tablature, slash. 

 

Select or adapt your tuning. 

 

Select the sound that you want to apply to your track. 

Note that you can listen to a preview of this soundbank by selecting the play 

button. 

 



If you want to save your settings for the next time you use the same instrument 

when creating a new track simply select the button Save instrument settings. 

 

Once that you applied your settings, select Create and finalise the creation of 

your track. 

 

Your track appears now in Guitar Pro 7. 

 

Note: you can easily find and modify these settings from the track inspector located 

on the right of your Guitar Pro 7  window. 

 

 

In Guitar Pro 7 each tracks have the same number of bars in order to keep the 

musical coherence. 

 

To delete a track: go to the Track > Delete menu. 

 

To move a track: go to the Track > Move up/Move down menu. 

 

 

3/A/2/2/ Track properties 

 

Track properties are now accessible from the track inspector located on the right 

of your Guitar Pro 7  window. 

 



 

 

This track inspector can be divided into  four sections as follow: 

 

● Track properties 

● Musical notation 

● Sounds options 

● Interpretation options 

 

Let’s have a deeper look into these categories. 

 

Track properties: 

 

From this section you have the possibility to name your track, give it a short 

name, allocate a specific color and icon. 

 

Note: the color of your track will appear in the global view  located at the bottom of 

your Guitar Pro 7  window. The short name will appear at the beginning of your track 

within your score. 



 

Musical notation: 

 

From this section, choose the  type of notation you want to display: standard, 

tablature, slash. 

 

Change your tuning if necessary. Note that you can listen to a preview of your 

tuning by selecting the play button. 

 

Access to the transposition options. 

 

Sounds options: 

 

These settings and options are developed lower in this guide see section: 3/B/4  

 

Interpretation options:  

 

Select your playing style: Pick, Finger, Picking or Bass Slap. 

Select your interpretation options: palm mute, accentuation, auto let ring, 

autobrush, stringed. 

 

Palm mute: this techniques consists in covering up your strings using the edge 

of your hand from your guitar bridge. The more you go up your neck, the 

stronger is the effect, until you obtain a totally muffled sound. 

Note that the Palm Mute is only available with certain playing styles. 

Accentuation: this option automatically accentuate specific times in your bars. 

 

Auto let ring: this option consists in letting resonate the strings independently 

of the duration of the note. A rest in your track will stop this effect for all the 

strings until a new note is played. 

Auto Brush: the notes included in a same chord are played with a slight offset in 

order to simulate the strumming effect involved by the use of a guitar pick.  

 

Stringed: the Stringed mode means that Guitar Pro 7 considers your instrument 

as a stringed instrument and so can ring several notes with the same pitch 

simultaneously. 

 



When this option is deactivated, the piano mode is activated by default. 

Note that this Stringed mode affects your effects. The notes are sorted by string 

in Stringed mode, but they are distinguished by pitch for the other playing styles. 

Using the Stringed mode, it is not possible to let ring your note if an other note of 

the same string is being played, while this option is possible when the Stringed 

mode is deactivated.  

 

 

3/A/2/3/ Multivoice edition 

 

Guitar Pro 7 handles up to 4 voices. 

Your track is composed of a main voice to which is attached 3 other voices. 

This allows for instance to edit notes of different values on the same beat. 

 

 

 

3/A/3/ Bars in Guitar Pro 7 

 

3/A/3/1/ Managing bars 

 

In Guitar Pro, there will necessarily be at least one bar per track. Thus, any given 

bar “B” will bear the same tone and signature on track T1, T2, etc. Similarly, 

adding a repeat sign (to open or close a section) will necessarily affect every 

track at once.  

 

This guarantees the musical consistency of the score, and a satisfactory result 

when you play it.  

On the other hand, you will have to precisely define each track. You won’t be 

able to create a hundred-bar guitar track, for instance, and a percussion track 

with only one bar playing in loops. You will have to reproduce the percussion bar 



on the 100 bars, either by using Copy and Paste, or by resorting to repeat 

symbols. (See Adding symbols.)  

 

Just as well, using the Bar > Insert Bar / Delete Bar menu will cause a bar to be 

added or deleted on every track.  

 

Guitar Pro automatically manages barlines.  

When you move the edition cursor to the right, it will automatically move on to 

the next bar if the current bar is complete according to the time signature 

chosen (for example 4 beats for a 4/4 time signature (See Understanding 

Notation). In case the bar isn’t complete yet, Guitar Pro creates a new beat 

whose duration is the same as that of the preceding beat.  

 

Whenever a bar is incomplete or too long, Guitar Pro displays it in red, unless of 

course it is the bar you are currently editing.  

The Status Bar shows you the actual duration of the current bar as well as its 

theoretical duration. Whenever you move your cursor over that part of the 

Status Bar a balloon will let you know which voice is incomplete.  

 

In Page or Parchment mode, it is possible to manually manage the number of 

bars per line. To do so, you must use the Bar > Force break line and Bar > 

Prevent line break menus.  

The Bar > System layout lets you choose the default number of bars per 

system. It resets the line-breaks.  

The Start at current system option tells the program how to apply the changes. 

If the option is checked the layout will be applied only to the bars that follow the 

current system. Otherwise the layout will be applied to the whole document. 

 

 

3/A/3/2/ The design mode  

 

 

Access the design mode from the edition palette or from the View menu. 

 



 

 

The design mode lets you change the sizes of bars inside a system, as well as the 

number of bars for each system.  

Line-break functions only affect the active track, or the multitrack view. It is 

therefore possible to create a different arrangement of bars for each track, and 

another for the multitrack view.  

To justify the last bar of the score to the right, you may simply add a line-break 

to that last bar.  

 

Once the design mode activated simply use the blue triangles as highlighted in 

the picture below to increase or decrease the size of your bars. The + and - icons 

allow you to add or remove bars to your system. This setting applies to your 

whole score. 

 

 

 



 

3/A/4/ Adding notes to your score 

 

You can write your notes either by way of tablature or of standard notation. (The 

“slash” notation is merely a representation of rhythm, and is therefore not 

designed for writing as such – but if you add a chord on the staff a slash will 

appear and you can then modify the rhythm.) Every note added into one kind of 

notation is instantaneously duplicated into the other.  

The edition cursor is symbolized by a yellow, green, blue, or grey square, 

depending on the voice it is on.  

Whenever it is on a note, the corresponding note in the other notation appears 

in a grey square. The TAB key allows you to switch back and forth from tablature 

to standard notation. If you are  

using a piano Grand Staff, the same key switches from left-hand staff to right-

hand staff.  

 

Clicking on the score doesn’t add any note, but it places your cursor where you 

want it to be. This is to prevent accidental modifications of the score when you 

just want to navigate over it.  

There are several ways to capture notes into the score. 

 

3/A/4/1/ Capturing notes on the keyboard  

 

Most of the capturing is done on the numerical pad:  

 

Move on the staff with the arrows; 

Use the numbers to enter the notes. 

Und - (minus) keys to change the note’s duration. 

Use the INSERT and DEL keys to insert or delete notes. 

 

 

3/A/4/2/ Capturing notes with the mouse 

 

If you prefer using the mouse, you can use the following tools:  

 



The  virtual guitar fretboard or virtual keyboard  (View > show virtual instrument 

menu) to choose the notes. 

The < and > buttons on the fretboard to move around the score. 

The note duration keys from the edition palette to change the lengths of notes; 

The Note > Insert a beat and Note > Delete a beat menus to insert or delete 

notes.  

 

 

3/A/4/3/ Capturing notes with a MIDI instrument 

 

The Sound > MIDI Capture menu allows you to use a MIDI instrument 

(keyboard, guitar, ...) to capture the score note by note. 

 

Go to the Sound > Audio/MIDI settings to set up your MIDI option 

 

 

 



3/A/5/ Insert invents 

 

3/A/5/1/ Understand automations 

 

It is possible to apply a change of tempo, volume or pan anywhere you want in 

your track. These changes are also called automations. 

The automations editor can be accessed from the Edit > Automations > Edit 

Automations menu, but also from the F10 keyboard shortcut or even from the 

automations icons located in the edition palette. 

 

 

You have the possibility to either hide or display these changes in your track. 

Furthermore you also have the possibility to insert some sound modifications 

(see Audio chapter). 

 

Note: the automations can be applied to either one of your track or to your master 

track, which is symbolised by a “M” from the automation icons available in the 

edition palette. 

3/A/6/ Adding symbols 

 



Guitar Pro allows you to insert all of the musical symbols into the score, and 

particularly those specific to the guitar. Most of these symbols are taken into 

account whenever the score is being played.  

Certain effects or musical symbols can be applied to a selection of notes — e.g., 

Let Ring, Palm Mute, etc. The symbols can be found on the Edition palette. 

 

3/A/6/1/ Symbols related to the bar 

 

 

 

 

Clef  

The Clef is an indication, in standard notation, as to which notes correspond to 

the lines. Guitar Pro handles 4 types of Clef (G-, F-, C3-, and C4-Clef), as well as 4 

types of octave clefs (8va, 15va, 8vb, 15vb). Whenever you change clefs, you can 

transpose the notes to keep the same pitch.  

 

Key Signature  

The key signature tells you which notes are meant to be altered by default — 

unless an accidental appears next to the note on the score. It thus indicates the 

tone in which the piece or passage is written. It is the same for every track, aside 

from transposing instruments when you are using the transposing tone mode 

(e.g., Bb clarinet) automatically managed by Guitar Pro.  

 

 

Time Signature  

The time signature indicates the durations of beats in the bars following that 

signature: the bottom digit corresponds to the number of divisions of the whole 

note, and the top one gives you the number of units in a bar (see Understanding 

Notation). Whenever a bar is complete according to the time signature, Guitar 

Pro will directly move on to the next bar if you add a note. Incomplete or 



overlooked bars will appear in red. If you have checked the Anacrusis option 

(Edit > Anacrusis), the first and last bars will not appear in red even when they 

are not completed.  

 

Triplet Feel  

Among other things, the triple feel means you play in a ternary way some bars 

that are written in binary mode for the sake of lightness of writing. Guitar Pro 

offers several motifs, the most common being the triplet feel 8th which lets you 

play a 4/4 signature in blues style, for instance.  

 

Free time bars 

Free-time bars are bars that are played freely in terms of rhythm and tempo. 

The barlines then appear as dotted lines and the time signature is in 

parentheses.  

Double bar-lines  

A double bar-line indicates a change of parts, of signature, or any other major 

change in the score. Guitar Pro inserts them automatically at every change of 

signature. You can also add more bar-lines with the button here to the left 

whenever you consider a change in the score to be important enough.  

 

Simple repeat sign  

This symbols means that the bar is meant to repeat exactly the bar preceding it. 

This makes editing and reading lighter, and will not work on the first bar of a 

score.  

 

Double repeat sign  

This symbol means that you are supposed to repeat exactly the two preceding 

bars. It will not work if placed on the first two bars of a score.  

 

Repeat open  



This symbol replaces an opening bar-line, and means that every bar that follows 

it will be played  

again a certain number of times, depending on the Repeat close sign (see 

below).  

 

Repeat close  

This symbol replaces a closing bar-line, and sends you back to the last Repeat 

open sign. A dialog window will open up for you to indicate the number of 

repeats you want.  

 

Repetitions  

This adds a repetition symbol at the beginning of the active bar. This tells you if 

the bar is meant to be played, depending on the number of times it has already 

been played. That symbol is used together with the repeat signs.  

 

 

 

Directions  

This function will add the Coda, Double Coda, Segno, Segno Segno and Fine 

symbols, as well as 11 other different types of coda jumps.  

 

Octave clef  

This little symbol means that you are to play the score an octave higher than 

what is actually written. If you click on that button the notes will be moved down 

one octave on the score, and a little 8va will be added. The other symbol 8vb 

means the opposite; and the two other buttons, 15va and 15vb extend it to two 

octaves. 

 

 

3/A/6/2/ Symbols related to the definition of a note  

 



 

 

 

Note’s duration  

A note’s duration can go from the whole note to the to the sixty-fourth note. This 

affects the beat on which the note is placed. If you wish to place on a same beat 

some notes that have different duration value, you can use the multi-voice 

editing mode.  

You can also add dotted notes, double-dotted notes, and simple or poly-

rhythmical n-tuplets.  

 

 

 Ties  

A tie links the note to the note preceding it. It lengthens the duration of that 

preceding note,  

therefore, by the duration of the tied note.  

 

Multiple ties  

You can also tie an entire beat to the beat preceding it.  

 

Fermata  

The fermata is also known as a hold, or a pause; and what it means is that you 

are to pause on that particular beat, at the discretion of the conductor. It is 

therefore a multi-track symbol. A window opens up to let you choose the symbol 

and the duration of the pause by adjusting the tempo.  

 

Accidentals  



Those buttons let you add any of the 5 different types of accidentals (sharp, 

double sharp, flat, double flat, and natural) to a given note.  

 

Changing the accidental  

This is to change the accidental without modifying the note’s pitch.  

 

Augmenting (or diminishing) by a half-tone  

You can raise with this button a note or an entire multiple selection by a half-

tone. The next button allows to similarly lower a selection by a half-tone. This is 

a useful tool to transpose an entire track, when used with Edit > Select all.  

 

Nuances  

The nuance (or note dynamic) defines the intensity with which a note is to be 

played.  

The buttons allow you to choose a dynamic for  

each note, from very faint to very strong . In order to get different dynamics on a 

same beat, please use different voices.  

 

 Crescendo/Decrescendo  

This attributes to a beat or group of beats (via multiple selection) a progressive 

rise or fall of the volume.  

 

 

 

3/A/6/3/ Symbols corresponding to effects  

 



 

 

Ghost note  

A ghost note is a faint note. The dynamic of a ghost note is automatically 

decreased. The note is displayed between round brackets on the tablature.  

  

Accented note  

Contrary to a ghost note, an accented note is played loudly. The dynamic of an 

accented note is automatically increased.  

 

Heavily accented notes  

A heavily accented note follows the same principle as an accented note, except 

in a more pronounced manner.  

 

Staccato  

A staccato indicates a very short note, independently of the note’s duration on 

the score. The note is displayed with a dot below.  

 

Legato  

The legato applies to several notes. (One speaks of legato phrasing.) It means 

that as many notes as possible are to be tied, so the way they are played is as 

fluid as possible.  

 

 Let ring  



The Let Ring option means that you let a note ring beyond its theoretical time 

value as indicated on the score. This is used a lot for arpeggios, for example.  

The Tools > Let ring options menu allows to attribute a Let Ring to each string 

over a group of bars.  

 

Dead note 

A dead note is short and more faint than a normal one. These notes are used 

with the Guitar to give a particular rhythmic effect. To make notes be dead 

notes, you have to put the right hand palm (for a right-handed person) on the 

strings near the bridge, or else just put the left hand fingers (for a right-handed 

person) on the string without pressing it. 

Natural harmonic  

The natural harmonic consists of playing the string open while you lightly touch 

it with the left hand (for a right-handed person) above a fret. The left hand finger 

has to be taken off at the same time that the right hand plays it. 5th, 7th and 

12th frets harmonics are very commonly used, while the others are quite 

difficult to obtain.  

 

Artificial harmonic  

Several types of harmonics are available:  

 

A.H. - Artificial Harmonic: For the artificial harmonic, the left hand finger presses 

the string like a normal note. It is the forefinger of the right hand that lightly 

touches the string several frets higher. The right hand has to play the note too, 

so it may be difficult.  

 

T.H. - Tapped Harmonic: The tapped harmonic is an artificial harmonic obtained 

by tapping quickly on the string several frets higher.  

 

P.H. - Pinch Harmonic: The pinch harmonic is produced with a pick, and consists 

in playing the string by letting the thumb that holds the pick lightly touch the 

string. This harmonic is best obtained with a distortion effect.  

S.H. - Semi Harmonic: The semi harmonic is similar the pinch harmonic, except 

you keep the natural resonance of the string in addition to the harmonic.  



You can obtain those in Guitar Pro in two different ways (see Stylesheet). 

 

Bend  

The bend effect consists of pushing the fretted string sideways with the left hand 

(for a right-handed person) to bend it, so the pitch of the note changes. The 

Bend window allows you to precisely set the type of the bend you want by 

adjusting its points. For sophisticated bends, you need to use ties in order to 

keep the score consistent in terms of audio playback.  

 

The Bend, Bend/Release, ... buttons allow you to define the base type of the 

bend. This choice is also reflected by a different symbol on the tablature.  

You can set the maximum level of the effect from a value of 1⁄4 to 3. The term 

“Full” is equal to a whole tone. This also affects how it is displayed on tablature.  

You can modify the curve by dragging its points with your cursor. Whenever two 

notes are tied, the bends extends to the entire duration. It is still possible to edit 

a bend on a tied note and place a hold on it, for instance, whose motif isn’t there 

by default.  

The Stylesheet allows you to display the bend in standard notation too.  

Here’s an example of what you can do: 

 

 

 

Fade in (violin effect)  

This consists in using the volume knob on an electric guitar to raise the sound 

and not hear the attack of the pick on the note.  

It can also create the impression of a “reversed track.”  

 



Fade out  

This consists in turning the sound progressively off with the guitar’s volume 

knob 

 

 

 

Volume swell  

This is a fade in leading directly into a fade out. 

Grace-note before the beat  

A Grace note is an ornamentation that consists in a very short note played 

before another one. In Guitar Pro, you can add a grace note for each string. 

However, it is not possible to set several grace notes on the same string. A grace 

note does not count for the bar duration and for the rhythm display.  

Grace-note on the beat  

Same as a grace-note before the beat, except here it starts right on the beat — 

thus slightly delaying the following beat.  

 

 Hammer-On/Pull-Off  

The hammer-on (HO) / pull-off (PO) is a transition between two notes played on 

the same string. The first note is played normally while the second one is not 

played by the right hand (for a right- handed person).  

For a hammer-on, the second note is higher than the first one, and it is played by 

tapping the tip of your finger on the string, while keeping the finger 

corresponding to the first note on the fretboard.  

In the case of a pull-off, the second note is lower than the first and is played by 

taking the finger off the first note.  

Guitar Pro determines automatically which effect is being used, based on the 

notes’ values. You can use the Stylesheet to customize the way the H/P will 

appear or not on the score.  

It is common enough for a series of hammer-ons and pull-offs to be linked 

together over two notes to play them legato:  



 

 

 

Upper Mordent  

An upper mordent is a melodic ornament in the form of a fast beat between the 

main (written) note and the higher note (relative to the key signature). 

 

Lower Mordent  

A lower mordent is a melodic ornament in the form of a fast beat between the 

main (written) note and the lower note (relative to the key signature).  

 

Turn  

The turn (in Italian “gruppetto,” “little group”) is a melodic ornament in the form 

of a melodic line of four notes turning around the main note and revealing the 

two notes next to it — higher and lower. The turn starts with note that is 

immediately lower, then the main note, the higher note, and ends on the main 

note. Just as the mordent, the turn is relative to the tune’s general harmony, as 

set by the key signature.  

 

Inverted turn  

The inverted turn starts with note that is immediately lower, then the main note, 

the higher note, and ends on the main note. Just as the mordent, the turn is 

relative to the tune’s general harmony, as set by the key signature.  

 

 Left-Hand Tapping  

This consists in hitting a fret with your left-hand finger with no previous attack 

on the note.  



 

 Slides  

Sliding means playing a note by sliding your left-hand finger (if you’re right-

handed) over the frets. Guitar Pro supports various kinds of slides:  

 

 

1/ The first note is played, and then the finger slides to the second one, which is 

not played.  

 

 

 

2/ The first note is played, and then the finger slides to the second one, which is 

played.  

 

 



 

3/ The note is played while coming from a lower fret (undefined). 

 

 

4/ The note is played while coming from an upper fret (undefined).  

 

 

  

5/The note is played, and then the finger slides to a lower fret (undefined).  

 

 



 

6/ The note is played, and then the finger slides to a upper fret (undefined).  

 

 

 Palm Mute  

The palm mute effects consists in muffling the sound by lightly touching the 

strings near the bridge with the palm of your right hand (if you’re right-handed 

person).  

The palm mute effect is represented by the “PM” symbol above the tablature.  

The level of the palm mute effect can be adjusted by way of the Palm mute slider 

on the Instrument panel.  

 

Tremolo Bar  

The tremolo bar is used on electric guitars to modify the pitch of all the notes (by 

rotating the bridge). The tremolo bar is operated with the right hand (for a right-

handed person).  

The way the Tremolo Bar window works is pretty much the same as the Bend 

window.  

 

Trill  

The trill effect consists of alternating quickly between two notes on the same 

string by a succession of hammer ons and pull offs. The Trill window allows you 

to choose the fret of the second note (the first one being indicated on the score), 

as well as the speed of the trill.  

This notation lightens the score, because alternated notes are not displayed.  

 

Left-Hand Vibrato  



Left-Hand Vibrato consists in quickly moving the left-hand finger (for a right-

handed person) on the string. The movement creates a variation in pitch.  

The vibrato effect is represented by a little wave above the tablature, and lasts 

until the note ends.  

 

Wide Vibrato (Tremolo Bar)  

The wide vibrato is stronger than the simple vibrato, and is obtained by using 

the vibrato bar. This effect is applied to the whole chord.  

The wide vibrato is displayed as a big wave above the tablature and ends as 

soon as a new note is played.  

 

 

 Wah-wah 

The Wah-Wah is an effects pedal. Possible options are On/Off and 

Opened/Closed. The Wah-Wah will affect playback only if you’re using the RSE 

and you have placed a Wah-Wah pedal in your effect chain. (See Sound settings).  

 

Arpeggio  

The arpeggio consists in playing every note in a chord one by one. The Arpeggio 

window lets you adjust the speed as well as the delay in playing. An Arpeggio 

Down goes from the lowest to the highest-pitched string. An Arpeggio Up goes 

from the highest to the lowest-pitched string.  

 

Brush  

Brushing the strings means strumming the strings in an energetic manner. This 

is much used for rhythmic guitar accompaniments.  

In the Brush window you can adjust the speed as well as the delay. The duration 

of a brush needs to be shorter than the beat itself, so every note has time to ring 

out before other notes get played.  

 

 Rasgueado  



This a much-used right-hand technique (if you’re right-handed) in flamenco 

guitar. Guitar Pro offers 18 rasgueado motifs that are all interpreted by the 

audio engine. The score will indicate Rasgueado on the chords, as well as the 

chosen motif.  

 

Left-Hand Fingering  

Left-hand fingering (for a right-handed person) indicates which fingers press on 

the strings on the fretboard. “T” is for the thumb, “0” for the forefinger, “1” for 

the middle finger, and so on. This can be changed in the Stylesheet.  

It is displayed before the note in standard notation, or under the tablature if 

there is no standard notation.  

 

 

Right-Hand Fingering  

Right-hand fingering (for a right-handed person) indicates which fingers pluck 

the strings. “P” is for the thumb, “i” for the forefinger, “m” for the middle finger, 

and so on. This can be changed in the Stylesheet.  

It is displayed before the note in standard notation, or under the tablature if 

there is no standard notation.  

 

Display string number 

For any given note, you can have displayed on the staff 

 

Pickstroke  

The pickstroke function lets you to set the direction for your pickstroke. A “v” 

means that the movement is upward, from the highest to the lowest-pitched 

string.  

 

Tapping  

The tapping effect consists in playing a note by tapping the corresponding fret 

with a finger of the right hand or of the left hand (often both). The string is not 

played as it usually is.  



The “T” symbol is displayed above the tablature to indicate a tapping effect. In 

Guitar Pro, a tapping effect is set for the whole chord. This effect is interpreted 

by the Guitar Pro Audio engine.  

 

Slap (bass)  

The slapping effect consists in slapping the string with your right-hand thumb 

(for a right-handed person) while rotating your wrist to obtain a percussive 

sound. The slapping effect is often followed by a popping effect (see below). 

Slap-bass samples are part of the bass sound-banks for more realistic effect.  

 

Pop (bass)  

The popping effect consists in popping one of the two highest strings with 

amplitude with the right hand forefinger (for a right-handed person). The 

popping effect is often preceded by a slapping effect (see above). 

 

Golpe finger/thumb  

Golpe is a percussion technique involving fingers (thumb or other fingers) and 

applied to the guitar body. 

 

Pickscrap out upwards/downwards 

This techniques consist by going up or down your guitar neck scratching your 

strings with your guitar pick. 

 

Dead slapped 

Dead slapped is a bass guitar technique which consist in giving percussive hits 

on the guitar strings using your left hand (for right handed players). 

 

 

 

3/A/6/4 Symbols related to annotation and design  

 

 



 

 

 

Chords [A] 

See Chord Diagrams.  

 

Slashes  

This is to integrate slash notation into the tablature: it convert the selected notes 

into slashes while keeping all information about the notes. Very useful to 

capture rhythmic motifs with transition notes.  

You can also ask for an entire slash track. (See Track Properties.)  

 

 Timer  

At any given point, this tells you the number of minutes and seconds (min:sec) 

that have elapsed since the beginning of the score.  

 

Section  

To add a section. See Adding sections.  

 

Prevent/Force Line Break  

This is to prevent the next bar from shifting to the next line, or forcing it to do so.  

 

Stems directions/ Beams grouping 

You can change the stems direction or force/break beams from the dedicated 

options in the edition palette. 

 

 

3/A/6/5 Automation symbols. 

 

 



 

 

 

 Tempo automation 

Insert a tempo automation.  

 

Master track volume automation 

Insert a volume automation on your master track. 

 

 Master track pan automation 

Insert a pan automation on your master track 

 

 Track volume automation 

Insert a volume automation on a single track 

 

 Track pan automation 

Insert a pan automation on a single track 

 

 

3/A/7/ Add lyrics 

 

Access the lyrics window from the Track > Show lyrics editor menu or directly 

from the lyrics icon located in the Edition Palette. 

 



 

 

 

3/A/7/1/ Choosing a track 

 

For the lyrics to appear on the score, you first need to select a track. The text will 

automatically get distributed over that track, following syntax (see Point 4 

below).  

As a general rule lyrics will be attributed to a vocal track, i.e. the track with the 

song’s melodic line. You can Nonetheless choose to place them on an 

instrumental track; but you will then have to check the syntax, as it is unlikely 

that the melody's rhythmical beats correspond to the syllables in the lyrics.  

Note also that you can choose to not attribute the lyrics to any track, and write 

them on the Lyrics panel only for information. In that case, you just need to 

uncheck the “Display on Track” option below the white box.  

 

 

3/A/7/2/ Lines 

 

You can type up to 5 lines of text. The lines will be displayed one under the other 

on the selected track.  

 

3/A/7/3/ The first bar 

 

For each line, you can determine a first bar after which the lyrics will be 

distributed. This is to avoid having to type spaces in before the lyrics.  



 

 

3/A/7/4 The lyrics 

 

The capture area is to type in the lyrics properly speaking.  

Guitar Pro automatically distributes each syllable over a different beat. The 

change of syllable occurs when a SPACE ( ) or a HYPHEN (-) appears. You may 

thus use the hyphens to separate syllables in a word. If you do not wish Guitar 

Pro to separate two words, however, you can replace the space in between them 

with PLUS (+) symbol.  

If you wish to leave a blank on a given beat, just add several hyphens or 

consecutive spaces.  

The line breaks are considered as spaces. On the other hand, several line breaks 

constitute only one space. You can thus make your text more open without 

problems.  

Parts of a text set in between brackets ([]) will not appear on the score. You can 

thus utilize the brackets to add comments or indicate the headings of various 

parts (“INTRO,” “VERSE,” “CHORUS,” ...).  

 

3/A/8/ Adding sections 

 

3/A/8/1/ What is a section? 

 

Sections are markers that allow you to easily get to any part of the score. They 

can be set as letters and/or names (Intro, Chorus, Verse, etc.).  

 

The markers are tied to the bars, and are therefore linked to the master track.  

To add sections, you can:  

 

Click on the section icon from the Edition Palette. 

Use the Section > Edit menu. 

 

   

You can navigate between sections by use of the shortcut keys. (Cf. Shortcut 

Keys.) 



 

Note: You can also go directly to a given section via the Edit > Go to... menu. 

 

3/A/9/ Cut, copy and paste options 

 

Access the Cut, copy and paste options from the Edit menu. 

 

3/A/9/1 Cut / Copy on a Single Track  

 

Since you are here cutting or copying from a single track (i.e., not in multiple 

selection), the function will not take the structures of the bars (signatures, etc.) 

into account. The function is multi-voice, however, and can work over several 

different tracks, even if the instruments are not compatible (e.g., guitar and 

piano), outside of percussion tracks.  

 

This is useful, therefore, as a tool toward transposing a score. 

If you wish to copy a great number of bars, it may be useful to use a multiple 

selection in the Global View in order to get a better overview of the copied bars. 

 

 

3/A/9/2/ Cut / Copy in multitrack Mode  

 

This takes the structures of the bars into account, and will copy whole sections 

by extending the multiple selection to the bars included in them. Cutting implies 

taking the selected bars out of all of the tracks at once.  

 

3/A/9/3/ Simple Paste  

 

This is to past the content of the Clipboard onto the current selection, or by 

default before the selection. In case the selection contains only one bar, other 

bars get added; or the current bar gets completed with the content of the 

Clipboard.  

If you place your cursor on an empty bar, the paste function will first fill in the 

empty bars and then create other bars as needed.  

 



3/A/9/4/ Special Paste  

 

This allows you to choose what you are going to paste and how many times so.  

 

3/A/9/5/ Insert or delete bars on a single track 

 

Considering the musical rigour of Guitar Pro 7 (see the Manage Bars section), 

inserting or deleting bars from one track only makes little sense, as a bar is 

meant to be present on every track at once.  

If you really need to insert or delete a bar on a single track, you may use the 

Copy/Paste functions as follows:  

 

E.g., Inserting a bar before bar 10 on the active track  

 

Select the whole range of bars from bar 10 to the end; 

Place your cursor on bar 11, and Paste; 

Empty the content of bar 10 (delete the notes). 

 

Follow the same principle to insert several bars. 

 

3/A/10/ Using wizards 

 

Guitar Pro includes many wizards to help you work faster when creating your 

scores. These wizards are available from the Tools menu.  

 

3/A/10/1/ Note-Related Wizards  

 

Let Ring Options  

Sets the Let Ring attribute for each string over a selected range of bars or notes.  

 

Palm Mute Options  

Sets the Palm Mute attribute for each string over a selected range of bars or 

notes.  

 



Using the wizards can save you lots of time. For example, in one step, you can let 

Guitar Pro know that you want the Let Ring function turned on for all of the 

notes on the four highest strings  

  

3/A/10/2/ Wizards for Organising the Score  

 

You can use these Wizards when you compose, after you have imported a track, 

or while you are capturing notes in standard, to get the best possible 

arrangement of the tablature.   

 

Bar Arranger  

Checks and arranges bars according to the notes’ durations.  

 

Complete/Reduce Bars with Rests  

Adds rests in bars that are empty or too short, and deletes the extra rests in bars 

that are too long.  

 

Automatic Finger Positioning  

Places the notes on tablature without changing the tune, so as to simplify the 

chord positions and movements of the hand.  

 

Move/Swap Voices  

Reorganises the voices over a multi-voice track.  

 

3/A/10/3/ Other Wizards  

 

Transpose  

Transposes the active track or all the tracks a given number of semitones up or 

down. This function does not transpose chord diagrams.  

 

Check Bar Duration  

Checks the whole score to detect bars that do not have the required number of 

beats.  

 

 



3/A/11/ Guitar Pro 7 Stylesheet 

 

Access the Stylesheet from the File menu.  

 

 

You can entirely customise the general outlook of your scores, and give it a 

professional finish.  

 

The chosen style is related to the type of score you have, and if you download a 

score whose style you don’t like you may always apply a default style (provided 

by the software) to it — such as Default Jazz or Default Classic; or else load up a 

style you will have saved beforehand.  

 

The Stylesheet includes 5 tabs:  

 

Page & Score Format: customise the page settings and the global spacing of 

notes.  

 



Systems & Staves: To customise the system layout and the symbols related to it 

(tuning, clefs, etc.).  

 

Header & Footer: To change font family and font size, the placement of texts in 

relation to the properties of the score (author, title, etc.).  

 

Texts & Styles: To change the font family and sizes of the main texts in the 

score.  

 

Notation: To customise the musical symbols so as to set up a score exactly as 

you’d like it to look: size of chord diagrams, visible or invisible H/P symbols, 

indications of fingering, and so on...  

 

 

3/A/12/ Drums and percussions 

 

You can use the keyboard shortcuts to enter notes into a drums/percussion 

track. Each line can present several articulations (e.g., the charleston can be 

open, semi-open, or closed), and you can use the 1, 2, 3 keys from the numerical 

pad.  

 

But also and mainly you can use your virtual instrument (View > Show virtual 

instrument menu) and select the element you want to add to your track directly 

from this window. 

 

 

 



The tablature being also available for drums you have the possibility to edit your 

drum track directly from the tablature notation by typing the MIDI number 

related to your drums element. 

See MIDI value table in appendix 

 

 

Note: You can choose which types of sticks you use with the drums, and the RSE will 

interpret the different types of strokes. Select this option from the track inspector 

located on the right of your Guitar Pro 7 window. 

In MIDI mode, the percussion tracks are always attributed to channel 10. 

3/B/ Work with a score 

3/B/1/ Finding Guitar Pro files 

 

Guitar Pro files are recognisable from their GP extension (7.x version),  

GTP (1.x and 2.x versions), GP3 (3.X versions), GP4 (4.x versions), GP5 (5.x 

versions), and GPX (6.x versions). 

 

Version 7.x can open all of those Guitar Pro files, whichever version they were 

made with, from version 1 and higher. 

 

Except for a few examples illustrating Guitar Pro 7 possibilities, Guitar Pro 7 is 

not sold with a built in free tabs catalog. 

 

To open a Guitar Pro file go to the File > Open menu. 

 

The last files you opened are accessible from the File > Open recent menu. 

 

Guitar Pro 7 allows you to open the following file formats: 

 

Guitar pro (.gpx) 

MIDI 

MusicXML 

TablEdit 

ASCII 

PowerTab 



 

A quick internet research will allow you to find thousands of compatible tabs for 

Guitar Pro 7. 

Once your tabs downloaded and saved on your computer, you will easily be able 

to retrieve them from Guitar Pro 7  by choosing the File > Open menu and select 

the tab of your choice. 

 

Arobas Music published a high quality and legal tabs catalog which we invite you 

to consult via http://www.mysongbook.com (see Chapter 5: mySongBook) 

 

3/B/2/ Navigating around the score 

 

Moving around a score in Guitar Pro is extremely easy, and you have several 

ways to do so.  

 

By Clicking on the Score: 

Clicking on the score moves the edition cursor to the pointed position.  

You can even move in the score during the playback to restart from the pointed 

position without stopping the playback.  

 

Using the Soundboard:  

Click on your track name in the Soundboard. The edition cursor gets placed on 

the first beat of the current bar in that track, or on the beat being played at the 

time.  

 

Using the Global View:  

To view a specific bar in a specific track, just click on the corresponding box in 

the Global View.  

 

Using markers: 

The Markers represent a useful means to move between different sections of 

the score. Use the Section menu, or the keyboard shortcuts.  

 

Using the Keyboard: 



The many Shortcuts allow you to easily navigate around your score — from note 

to note, bar to bar, or track to track.  

 

3/B/3/ Display settings 

 

To make the most of Guitar Pro 7 it is important to set your display options 

carefully. 

 

Screen layout: 

 

Except for the work area and the toolbar, you have the possibility to either hide 

or display the Guitar Pro 7 panels, which will allow you a better visibility 

especially in playback mode. 

Select the view option of your choice from the toolbar in order to hide or display 

these panels. 

 

If you decided to hide the mix table, use the Track menu, the LCD screen or 

even the keyboard shortcuts to switch tracks. 

 

You also have the possibility to use the the totality of your screen by choosing 

the Full screen mode from the View > Full screen menu. 

 

Display parameters for all the files: 

 

Different display modes are available in Guitar Pro 7 from the View menu. 

 

Vertical or horizontal successive scrolling of your page in Page mode 

Grid view (the number of horizontal pages adapts to your window size) 

Parchment mode 

Vertical and horizontal scrolling in Screen mode. 

 

Use the Page or Parchment mode if you want to work directly on the paper view. 

The parchment mode removes the page breaks. 

Using the vertical Screen mode, the bar organisation is done automatically while 

the horizontal Screen mode is useful in multitrack view.  



 

Display options for each file: 

 

Guitar Pro 7 allows you to either display one single track, all your tracks at the 

same time or even some of your tracks. 

Activate the multitrack mode from the View > Multitrack menu (F3). 

All your tracks will be displayed when the Multitrack is activated. 

Simply disable this option in order to display one single track. 

 

Each one of your track is accessible from the Global View located at the bottom 

of your window. 

This is also from the Global View that you have the possibility to hide or display 

some of your tracks when the Multitrack option is activated. To do so select the 

visibility icon as follow: 

 

 

 

Note: the multitrack mode is also available from the global view, select the Multitrack 

icon located above the visibility icons. 

 

 

3/B/4/ Audio settings 

 

Guitar Pro offers two audio technologies to play your score: the RSE and MIDI. 

 

The RSE [Realistic Sound Engine] is a unique technology. It relies on sound 

samples made from genuine guitars, basses, drums, and about a hundred other 

instruments recorded in professional studios. The RSE allows for some 

extremely realistic playback of scores.  

By default Guitar Pro 7 will play your tracks in RSE mode as it is the favorite 

mode of users. 



Still you can force the MIDI mode for the opening or the creation of your track by 

selecting this option from the Preferences > General tab menu (access the 

Preferences from the Guitar Pro 7 menu on macOS and from the File menu on 

Windows). 

 

You also have the possibility to play some of your tracks in MIDI while other are 

played in RSE, by selecting this option from the track inspector. 

 

To play all your tracks in MIDI, simply go to the Sound > Switch all tracks to 

MIDI menu. 

 

Inversely, to convert all your MIDI tracks to RSE, go to the Sound > Convert all 

tracks to RSE menu. 

You can select the soundbank and the effects that you want to apply to your 

track from the track inspector. 

 

3/B/4/1/ Audio settings in Guitar Pro 7 

 

Audio settings have been completely revisited in Guitar Pro 7. 

 

One sound is composed of one bank (instrument) plus one effects chain. 

The banks allows to choose the gross “unplugged” sound of an instrument. 

The effects chain, which is generally composed of a few effects pedals and one 

amplifier, is then applied to the bank, this combination generates a complete 

sound. 

 

When you create your track, a wizard window pops up. This window allows you 

to choose an instrument model to which will be applied a default sound. 

 



 

 

From this window, you have the possibility to choose an other sound for your 

track. 

 

 

 

Once your track created, you can retrieve its sound options from the track 

inspector. 



One track can include several different sounds in order to allow sound 

automations (sound changes), and that from different location all over your 

track. 

The “+” button allows to add a sound to the track, eventually duplicating the 

former sound to add a small modification (for example, the activation of a 

distortion effect pedal). 

 

The “A” button allows to access to the automation window and set up these 

different sound changes (see below). 

Choose a different sound from the track inspector: 

 

 

 

Select your sound name to choose a different sound among the hundreds of 

available sounds. 

Standard sounds for each category are listed in a first menu, but the Signatures 

sub-menu gives you access to hundreds of additional sounds, all inspired from 

the greatest standards of music. 

 

 

Fine tuning : 

 

By selecting the icon of your sound construction (just below the sound name), 

you will access to the details of both the instrument and the effects chain 

currently applied. 

 



Title : 

 

The title is what will be displayed on your score if this sound is used for a sound 

change. By default this title is the same name as your sound, but it can be 

recommended to update it (f.i. “w/disto” if you change your sound for a 

distortion sound). 

 

Bank: 

 

By selecting your bank name, you have the possibility to choose an other bank 

for this sound. 

By selecting the bank icon (left from the name), you can configure this specific 

bank parameters (mono/stereo and mics). 

 

 

Effect chains: 

 

6 different slots are available. Select one affected or empty slot to choose the 

effect you want to add.  

You can set an effect to an other slot by using the Move down/up menu 

available by selecting the Options button at the right of your slot. 

You can finally copy/paste/delete an effect from this same Options button. 

 

 

 



When you choose an effect, or when you select the icon of this effect (left from 

the effect name), a setting window pops up allowing you to change the settings 

of this effect. 

 

 

 

You can activate or deactivate each effect via the power button (bypass) located 

on the right. 

 

 

Save a user sound preset:  

 

The Options button located right from the name allows you to save your own 

sound preset via the Save as user sound preset menu. 

 



 

 

You just have then to name your sound, affect it a family and a type of 

instrument, so that you will be able to easily retrieve it from the track inspector. 

Your sound will be listed with the list of available sounds of each category. 

 

 

 

 

 

3/B/4/2/ Insert a sound change 

 

Easily insert a sound change anywhere you want in your track. 

To open the sound automations window go to the Edit > Sound > Sounds 

automation or use the “A” button from the track inspector. 

 

From this window: 

 

Select Add an automation at the cursor and select the sound you want to 

apply. If necessary update the position of your sound change. 

 

You also have the possibility to change your sound from your cursor location by 

using the Edit > Sounds > [sound name]. “[sound name]” being one the sound 

that you will have previously created  from the track inspector (Sounds section). 

 

If you want to force the use of a sound on your track independently of the cursor 

position, you can use the padlock icon for this sound (from the track inspector, 

Sound section). 



 

 

 

3/B/4/3/ The MIDI sound  

 

MIDI – Musical Instrument Digital Interface. This is a protocol, a universal 

language to transmit digital musical information between computers, 

synthesizers, sequencers, etc. MIDI files include messages that can precisely 

describe a score: notes, rhythm, tempo, instrument, etc.  

 

 

The quality of the sound you produce will depend on your equipment 

(soundcard, actual or virtual synthesizer) – and not on Guitar Pro as such, as the 

program will merely send information about pitch and duration to your 

equipment for it to transform that information into sound.  

Similarly, the list of the instruments available in Guitar Pro is defined by the 

general MIDI norms, and is not extensible unless you use some specific 

equipment.  

 

 

MIDI Output: 

Guitar Pro can use up to 4 simultaneous MIDI ports. You can assign a different 

MIDI device to each of those ports.  

 

It is recommended to choose the best MIDI device for port 1, as this is set as the 

default one when a new track is created in Guitar Pro. 

 

To apply a MIDI playback to your score, either go to the Sound > Switch all 

tracks to Midi menu or select the MIDI option for the selected track from the 

Track Inspector. 

This one will offer you the possibility to mix RSE tracks with MIDI tracks. 

 

You can finally force the MIDI mode for all tracks at the opening and creation of 

your score. To do so go to the Preferences, General Tab, and select the option 

Force playback with MIDI. 

 

MIDI Capture: 



 

You can capture notes via a MIDI instrument. (See Capturing notes with a MIDI 

instrument) 

  

Ports and Channels: 

 

In the Instrument panel you can choose which port and which channel(s) to use 

for each track.  

By default Guitar Pro assigns 2 channels to every track in order to better the 

effects playback (the effects get played on a separate channel so as not to affect 

the notes that bear no effect).  

If two tracks are using the same channels on the same port (roll down the list to 

get the tracks’ numbers), their audio properties (instrument, volume, pan) will be 

tied. It is therefore advisable to use only one channel per track if your score 

contains a great number of tracks.  

By convention, the percussions tracks are always assigned to channel 10 (a MIDI 

norm). 

You may choose to activate the “force 11-16” option to make Guitar Pro use one 

MIDI channel for each string for a given track (which is useful if you have several 

different bends on a same beat).  

 

Note : it is possible to change these settings track by track by switching the track to 

MIDI. New options will appear from the Track Inspector to change the port and 

channel. 

 

 

3/B/5/ Playback options 

 

Guitar Pro has been designed to facilitate the learning of a score. Many playback 

options are available.  

 

Launching Playback: 

 

To start playing a score, you can use the playback options available from the 

Sound menu, but also the space-bar or even the toolbar playback options. 



 

If you only wish to play a specific part of a score, you simply need to select this 

specific section first using your mouse.  

 

Tempo options: 

 

Tempo: 

The Edit > Automations > Edit automations menu opens the automation 

window and allows to define the initial tempo, from the same window you also 

have the possibility to program tempo changes. 

 

This window is also accessible from the toolbar located at the top of your 

window. 

 

 

 

During the playback, the current tempo is displayed from the LCD  screen 

located in the toolbar. 

 

Relative speed and progressive speed: 

Guitar Pro 7 allows you to play your score at a different tempo than the one 

originally set up, what can be really useful for practice. You can activate this 

feature from the Relative Speed icon located in the toolbar, and choose a 

predefined coefficient speed or set up the value of your choice. 

  

The progressive speed allows you to increase the overall speed of your score 

every X repetitions.  

 

 

 

 

The relative tempo button allows to affect a different tempo coefficient in order 

to speed up or slow down the playback without modify your file. 

 

 



 

 

This coefficient is customisable and varies from 10% to 300%. Simply select the 

same button to disable this feature. 

 

Note: in order to play in loop a specific section of your score, you simply need to 

select this specific area with your mouse prior to launch the playback. 

 

 

Métronome and count-in: 

 

The Sound > Metronome menu allows to activate the metronome during the 

playback. 

 

The Sound > Count-in menu allows to start your playback with a count-in, 

equivalent to one or two bars duration. It allows more time for you to handle 

your instrument before playing but also gives a good overview of the current 

tempo and so start your playing in rhythm. 

When the loop is activated you do have the possibility to repeat the count-in for 

each loop. 

These options can easily be activated/deactivated from the LCD screen located at 

the top of your window. 

It is possible to set up the metronome volume, the count-in length but also to 

activate the count-in between the loops. 



 

 

 

The Soundboard: 

 

The Soundboard allows you to set up the audio parameters of your track such as 

instrument, volume, panoramic, .... These parameters correspond to the initial 

settings of the score, but you can add changes anywhere you want in your score. 

 

The equalisation parameters can be indifferently modified during the playback. 

You can for instance launch the playback, click on the instrument of a specific 

track and select the available instrument one by one in order to check which one 

has the best sonority.  

 

The soundboard includes for each track a Solo option (symbolised by a 

headphone) and a Mute option (symbolised by a crossed out speaker). This 

allows respectively to play one or several tracks in solo (without the other tracks) 

and to mute one or several tracks. 

 

 

 

If you want to listen to only one or two tracks, it is easier to apply the Solo mode 

for these tracks. 

On the other hand, if you want to mute only one or two tracks (to play them 

yourself for example), it is easier to use the Mute option. 

 

 

The equaliser: 

 



The equaliser is directly accessible from the soundboard and allows you to set 

up your track as you want to, but also to charge predefined presets for each type 

of instrument. Once selected, your preset is directly applied to your track. 

 

 

 

 

 

RSE/MIDI mix: 

 

Guitar Pro 7 offers you the possibility to mix the RSE sound with the MIDI sound. 

That means that you can decide to play some of your tracks in RSE mode and 

the others in MIDI mode, and that for the same score. 

The RSE and MIDI options can be activated or deactivated  track by track, directly 

from the track inspector. 

Depending on your hardware configuration, it might be necessary to adjust the 

latency in positive or negative, and  therefore make sure it is well synchronised 

with the RSE. 

This setting can be configured from the Preferences > Audio MIDI tab (access 

the Preferences from the Guitar Pro 7 menu on macOS and from the File menu 

on Windows). 

 

  

3/B/6/ Printing 

 

Go to the  File > Print menu to get a printout of your score. 

Use the stylesheet (File > Stylesheet) to customise fonts, page setup, margins, 

and all other page settings.  



 

Note: please make sure to install the last available updated for your printer. 

 

3/B/7/ Files and tabs import 

 

3/B/7/1/Midi import 

 

The File > Import > MIDI allows to import a MIDI file into Guitar Pro. 

Guitar Pro supports MIDI formats from 0 to 1. 

 

Quantification: the quantification determines the rhythm accuracy of imported 

notes. 

For example, if the quantification is based on the quarter note and that the 

original rhythm was four eight notes, these four eight notes will become a 

quarter note chord based on the beat. 

On the other hand, if the quantification is based on the sixteenth note and that 

the MIDI file includes real human playing, and so with approximative rhythms, a 

too high quantification may altered the score precision by adding notes where it 

is not necessary. It is then necessary to adjust the file based on the original file 

and the desired rendering.   

Only percussion tracks placed on the canal 10 will be by convention considered 

as a percussion track. 

 

  

Import options: 

 

Different options are available for the MIDI import. 

 

Selection of the tracks to import 

 

Quantification choice 

 

Fix the minimum length of the imported notes. For a live recorded file, it is 

recommended to choose a low quantification, as the duration will be 



approximatives, on the other hand for an accurate but complex file, a high 

quantification will be recommended. 

 

Import of dotted notes 

 

Allows to transform tied notes in dotted notes if the general value of the note 

allows it. 

 

Increase the note value 

If there is a silent between a note and the next one, this one will be increased in 

order to obtain a less complex and choppy rhythm.  

 

Authorise the multivoice 

If some notes are overlapping on the duration, one of the note will be placed on 

an other voice for a better fluidity.  

 

Autorise triplets 

If your file is live recorded, it is advised to deactivate this option. 

 

3/B/7/2/ Import ASCII  

 

To import ASCII files go to the File > Import > ASCII menu. 

 

Guitar Pro is able to analyze the ASCII text files to extract the musical 

information. It is possible to get a Guitar Pro score you can play, modify, or print 

from a symbolic score.  

 

Guitar Pro imports notes, rhythm, effects and bar changes. The import is done 

on the active track. So it is possible to successively import several files 

corresponding to the different instruments.  

 

The imported file can contain comments or misc. text, Guitar Pro is able to 

extract the tablature whatever the content of the file is. 

 

The only rules to respect for the import to work are:  

 

Lines have to be represented by series of hyphens: « - ». 



Bar changes have to be indicated by a vertical bar on each of the strings: « | ». 

No empty line has can be present between two strings of a same line of 

tablature. Comments inside the tablature lines are prohibited.  

Once an ASCII import is complete, it is often necessary to review the rhythm, so 

the bars be complete.  

 

The Check bar duration tool (Tools menu) can come in handy in that case. If 

the score is played and the bars are not complete, the rhythm will be false, and 

the notes beyond the bar duration will not be played.  

 

 

3/B/7/3/ Import MusicXML  

 

The File > Import > MusicXML menu allows you to import standard and 

compressed MusicXML files into Guitar Pro.  

Created by Recordare®, MusicXML is a XML description of a music score. This is 

a universal exchange format that is now available in most music softwares 

programs.  

 

3/B/7/4/ Import PowerTab  

 

The File > Import > PowerTab menu allows you to import from PowerTab® 

format. 

 

3/B/7/5/ Import TablEdit : 

 

The File > Import > TablEdit menu allows you to import from TablEdit® format 

 

 

3/B/8/ Export a score or a file. 

 

3/B/8/1/ MIDI export 

 

The File > Export > MIDI menu exports the score into a MIDI (format 1) file 

(.mid). 

 

To choose not to export a track, just mute it from the Soundboard.  



 

Guitar Pro allows you to use 2 channels for a single track to enhance the sound 

restitution. Some software does not support this functionality. So if you have a 

problem opening Guitar Pro exported MIDI files, use a single channel per track.  

 

 

3/B/8/2/  ASCII export   

 

The File > Export > ASCII Tab menu lets you export the active track into ASCII 

format  

 

3/B/8/3/ MusicXML exports 

 

The File > Export > MusicXML menu lets you export the score into MusicXML 

format.  

 

3/B/8/4/  Audio exports :  MP3, WAV, OGG, FLAC, AIFF  

 

Guitar Pro 7 allows you to export your Guitar Pro scores into the following audio 

formats: MP3, WAV, OGG, FLAC, AIFF 

 

Export from the File > Export > Audio menu. 

 

This will allow you to save an audio copy of your score, and for instance allow 

you to listen to it by use of any regular audio player.  

 

If you want to export just a specific part of your score, simply make sure to do a 

multiple selection prior to your export. 

 

 

3/B/8/5/ PNG export 

 

The File > Export > PNG menu allows you to save the score in the form of a 

picture file. This function is handy if you plan to publish your creations on a web 

page, for example.  

 



The image you get from the export is exactly the same as the image you see in 

the Guitar Pro editor. The Export button saves the image.  

 

The size of the image is affected by the zoom value. You can therefore obtain 

images of various sizes depending of what you want to use them for  

 

The PNG format is adapted to computer screens. If you wish to insert your score 

into a document for print, we recommend you use PDF.  

 

Note: PNG Export is really only useful in Page mode. 

 

 

3/B/8/6 PDF export  

 

The File > Export > PDF menu allows you to export the entire score into the 

Adobe® PDF® format, readable and printable by anybody who uses the free 

Adobe® Reader® software, or any other PDF reader.  

 

 

4/ Tools 

 

4/1/ Chord diagrams 

 

The Chord Diagram Generator not only allows you to make your tablature richer, 

it constitutes a genuine reference tool for guitarists, even independently of the 

tablature. 

 

To open the chord diagram tool, go to the Note > Chord menu or use the “A” 

keyboard shortcut. 

Just like every tool in Guitar Pro, the Chord Diagram Generator automatically 

adjusts to the tuning chosen for the active track. You may therefore generate 

chord diagrams even for exotic tuning modes — such as cannot usually be 

found in chord charts.  



 

The chord diagram tool is composed of several areas, these one are interactives 

and it is important to know how they work in order to make the best out of the 

chord diagrams tool. 

 

 

 

Chord building: 

 

The first part allows to build the chord by its name. Thousands of possibilities 

are possible. 

When you select a tonality among the available chord diagrams list, Guitar Pro 7 

displays the position of the hand for this specific chord. 

A list of equivalent diagrams is available, select the button next to the suggested 

chord name to have access to other names.  

 

You can define a chord inversion (in which the Bass note differs from the root), 

or simply specify which note you want for the Bass (on the lowest string).  

 



From this window, you have the possibility to hide or display in your score, either 

the name, the diagram or the fingering for your chord. 

 

Main diagram: 

 

Once your tonality selected, your main diagram appears, that means that he will 

be added to your score, and so as its name, its fingering, and theoretical 

construct. 

 

The fingering is displayed in the circle of the note (1 for the index finger, 2 for the 

middle finger and son on…) it also appears below the chord diagram, to modify 

it, a simple right click over a finger position will allow you to change the 

fingering. 

 

The option Highlight root note allows to change the colour of the root note on the 

diagram (it is not reflected on the score). 

 

You can built a diagram by selecting this one directly: 

Select a fret to add or remove a note. 

Use the scrolling bar to change the root fret. 

Barre chords are automatically suggested by Guitar Pro. 

Eventually change the default name suggested by Guitar Pro 7, this one will 

appear in your score. 

Three chord name formats are available: Classic, Jazz and Rock. 

If you want to keep the chord name as appearing in the field, you need to make 

sure to put an apostrophe (‘) just before the chord name. 

 

Just above the diagram, a circle symbolise a string played open, while a cross 

symbolise a string which is not played. 

 

Diagrams list: 

 

A list of possible diagrams for the chord is displayed in the main area, those are 

listed by difficulty order. 

  

Select one of this diagram to make it your main diagram. 



To listen to the selected diagram, select the playback button available from the 

top right corner of your Chord diagrams window. 

 

Miscellaneous: 

 

When you open the chord diagrams window, the notes related to the selected 

beat are automatically placed on the main diagram if no diagram was previously 

defined for this beat. 

 

When you validate the chord diagrams window, the notes of the main diagram 

are automatically added to your score if no note was previously defined for the 

selected beat. 

 

The Stylesheet (access from the File menu) allows to change the diagrams size 

and their position in your score. 

 

In short terms, the chord diagrams tool can have many functions: 

  

Adding  chord diagrams to your tablature. 

Learning the different positions possible on the fretboard for a given chord. 

Knowing the name of a chord you found on your instrument, and learning other 

possible positions or fingering for that specific chord. 

Retrieve the positions of the standard chords with exotic tunings of your 

instrument. 

 

4/2/ Scales 

 

The scale engine: 

 

The Scale Engine allows you to view and listen to a great number of scales in any 

tonality. It can also retrieve the scale used in a score.  

To activate the scale engine go to the Tools > Scales menu 

 



 

 

 

Guitar Pro proposes over 1000 different scales. To find a scale, you may either 

check some Tags to filter your search, or use the search engine based on a key 

word. The scale will appear in the chosen tone.  

Guitar Pro displays the notes on the scale. To listen to them, click on the “play” 

button.  

Guitar Pro also shows the way the scale is constructed, with an indication of 

intervals and semi-tones between notes.  

Just like all of the other Guitar Pro tools, the way the notes are displayed on the 

fretboard is related to the tuning chosen for the active track.  

 

 

 

 

Analysing the scale used in the score: 

 



Select the bars to analyze from your score, and click on Find scales from 

selection. 

Guitar Pro shows you a list of possible tones and scales, and indicates 

percentage statistics of their occurrences, in descending order.  

 

If the scale search gives bad results, it may be because the score includes a 

change of tones. In that case, you need to find that change by ear, and limit your 

scale analysis to a range of bars with no tonal change.  

 

Guitar Pro does not allow you to directly place a scale from the Scale tool on the 

tablature. However, by displaying the scale on the fretboard, it is then easy to 

click on it to place the notes on the tablature. You can also right-click to make 

the cursor move to the right after adding a note. The operation is then really 

quick. 

 

4/3/ Virtual instruments 

 

4/3/1/ Virtual guitar fretboard and virtual keyboard 

 

Virtual guitar fretboard: 

 

 

 

The virtual guitar fretboard offers many features. It can be used to view the 

notes of the score, to enter notes, or to visualise the scales.  

 

To activate the fretboard, make sure to select a guitar track first and go to the 

use View > Show virtual instrument menu. 

 

The fretboard automatically adjusts to the active track settings. The number of 

strings and the position of the capo are set by the track settings. If you change 

the active track, the fretboard will automatically update to reflect the new track.  

 



To add a note on your score, simply select it from the guitar fretboard. 

 

Virtual keyboard: 

 

 

 

 

Just like the fretboard, the keyboard allows to view and to enter the notes of the 

score. It can also show the scales. 

To activate the Keyboard, go down the View > Show virtual instrument menu, 

on a track corresponding to a non-fretted instrument.  

 

To add a note on the score, just click on a key. To delete a note, click on that 

note. The [< >] buttons let you move around the score — avoiding the use of the 

computer’s keyboard if you prefer to capture notes with the mouse. 

Display options: 

 

Select the gear wheel located on the left of the virtual instrument window to 

access these different view options: 

 

Show [Beat]: to see only the notes on the selected beat. 

Show [Beat + Bar]:  to see the notes of the selected beat and the notes of the 

active bar. 

Show [Beat + Next Beat]: to see the notes of the selected beat and the notes of 

the next beat.  

 

Displaying the note pointed at:  

 

The note pointed at by the mouse is displayed. You don’t need to click on the 

fretboard.  

 

Opening the Scale Engine:  

 



Access directly to the scale tool window from your virtual instrument. You can 

still visualise your scale while entering your notes. 

 

 

4/3/2/ Virtual drums 

 

Access the virtual drums from the View > Show virtual instrument window. 

You can select the notes of your drum tracks directly from the virtual drums 

window. 

 

 

 

 

The virtual drums window displays all the available drums elements. 

 

Select one of this element, Guitar Pro 7  will show you which keyboard shortcut 

is dedicated for this element (numeric keypad), this will make your edition easier 

and faster. 

 

To add a note on the score, just click on a key. To delete a note, click on that 

note. The [< >] buttons let you move around the score — avoiding the use of the 

computer’s keyboard if you prefer to capture notes with the mouse. 

Display options: 

 

Select the gear wheel located on the left of the virtual instrument window to 

access these different view options: 

 

Show [Beat]: to see only the notes on the selected beat. 

Show [Beat + Bar]:  to see the notes of the selected beat and the notes of the 

active bar. 



Show [Beat + Next Beat]: to see the notes of the selected beat and the notes of 

the next beat. 

 

Displaying the note pointed at: 

 

The note pointed at by the mouse is displayed. You don’t need to click on the 

virtual drums element. This window shows you the name of the drums element 

pointed at but also its MIDI value. 

 

 

4/4/ Polyphonic tuner 

 

Guitar Pro 7 comes with a built in professional polyphonic tuner easily accessible 

from the toolbar located at the top of your window (see toolbar presentation: 

section 2/2/4). 

 

One single brush allows you to check your tuning for all your strings. 

 

4/5/ Metronome 

 

The metronome is accessible from the toolbar located at the top of your window 

(see toolbar presentation: section 2/2/4). 

 

4/6/ MIDI capture 

The MIDI capture allows you to enter notes into your score via a MIDI instrument 

(see section 3/A/4: Adding notes to your score). 

 

4/7/ Line In 

 

Guitar Pro 7 offers you the possibility to plug your guitar via a USB interface 

(your soundcard for example) and hear you play in the software using by the 



occasion the effects models of your track via the numerous audio preset and 

available soundbanks. 

You can then accompany the songs that you want to play in Guitar Pro 7 fully 

taking the role of the guitarist. 

 

 

For example: 

 

Once your guitar is plugged in and the Line In option activated, select the guitar 

track of your choice. 

Mute this guitar track from the Mute option available in the soundboard. 

Launch the playback. 

Your score is scrolling but your guitar track remains silent. 

You have now to play this guitar track using your own guitar. 

Your playing is immediately reproduce in Guitar Pro 7, in real time with no 

latency, using the predefined sound applied to your guitar track. 

If there is any sound change in your track, this one will be automatically applied 

depending of your cursor position. 

 

Use the Line In: 

 

Warning: An external soundcard or an audio peripheral connected via USB is 

necessary to link your guitar to your computer. 

 

Select the Line In icon located on the right of your toolbar (see section 2/2/4/ 

Panels and Inspectors). 

 

Select the gear wheel to check that you well selected your soundcard has audio 

Input from the audio preferences (Preferences > Audio/MIDI tab). 

 

 

Activate the option. 

 

Once the Line In activated, you have to choose the right audio input for your 

soundcard (the one where you plugged your guitar). 

 

You can then apply some specific settings: 



 

Input gain: allows to increase or decrease the output gain of your soundcard, 

and so allow you to adjust your sound rendering. 

 

Effects chain: allows to choose if you want to use the effects chain of your track 

or not. For example if you use an effects simulator instead of the Guitar Pro 7 

effects, it is preferable to disable it for tuning. 

 

Noise Gate: this setting allows to prevent background sound when your guitar is 

plugged in but you are not playing it. To set up this option, you have to slowly 

turn the potentiometer up, until you notice that the background sound 

disappeared (guitar plugged without playing). 

 

Volume: allows to adjust the output volume of the Line In instrument in the 

general mix. 

 

Limiter: allows to prevent the feedback effect by decreasing the volume of 

sounds exceeding a certain limit. 

  

 

 

Note: you can change the effect chain at any time from the track inspector. 

Bare in mind to turn off the Line In option after using it.  

 

Important: to make the best out of the Line In feature and for an optimal use, it 

is strongly recommended to use the same soundcard for both the audio input 

and the audio output. 

 



4/8 File protection 

 

Guitar Pro 7 allows you to protect your file and decrease the possibilities to see 

it modified, what could be really useful if you want to protect your work or for 

instance share it with your students and prevent modifications, in case you are a 

teacher. 

 

Go to the File > Lock/Unlock menu and access these protection options: 

 

Finalise: allows to finalise a file and prevent unwanted modifications, you simply 

have to unlock your file to be able to modify it again. 

 

Lock editing: prevent any modification, the file is protected by a password. This 

option is useful for teachers wishing to distribute their files and avoid 

modifications by students. 

 

Lock opening: makes it impossible to open the file without the password. Useful 

for websites selling online lessons for instance. 

 

Note: please make sure to note or save your password as you won’t have any 

possibility to open your file if the password is lost. Also note that the password does 

not constitute an absolute guarantee that your file can not be opened by a person 

with dubious intentions. It is a soft protection which does not involve complex 

algorithms. 

 

 

 

 

5/ mySongBook 

 

mySongBook is the official tablatures website of Arobas Music 

It is a qualitative and legal offer respecting copyright by remuneration of the 

copyright holders via their official publishers. 

 

Thousands of scores edited by professional musicians are available on 

mySongBook. You will find unpublished arrangements for guitar, bass or other 



stringed instruments, as well as complete and accurate scores respecting all the 

instruments included in the original pieces (guitar, bass, battery, keyboard and 

lyrics). 

 

Our tabs audio settings are all made by professionals, each tab is as faithful as 

possible to its original version. As a result, mySongBook is the best option to 

make the best out of Guitar Pro 7 new Line In feature. 

 

Open a mySongBook score: 

 

Create an account or connect to the www.mysongbook.com website. 

Select one of your tab from your purchased list or any available tab if you 

purchased a monthly subscription. 

 

Launch your tab from the mySongBook website. 

Your tab will open directly in Guitar Pro 7 . 

 

A free tab is available each day as a “Free tab of the day”. You just need to create 

an account in order to access it. 

 

 

http://www.mysongbook.com/
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